Actualizar la versión PHP de WordPress

Algunas veces, cuando estás instalando un plugin en un sitio que utiliza WordPress, compruebas que no funciona, porque está programado para hacerlo con una versión de WordPress superior a la que tú tienes en tu instalación. Hoy te explico cómo actualizar la versión PHP de WordPress.

Solución Rápida

Para cambiar la versión de PHP de tu instalación de WordPress, debes acudir al Panel de Control de tu hosting (CPanel). Ahí busca dentro de la sección “Software” un icono que pone “Seleccionar versión PHP”. Ahí aparecerá un desplegable con las últimas versiones de PHP disponibles. Selecciona la que necesitas y guarda los cambios.

¿Qué es PHP?

PHP es el acrónimo de Hypertext Preprocessor, un lenguaje de programación de código abierto, muy utilizado y especialmente útil para la programación web.

En nuestro caso, es muy útil aprender esto porque es el lenguaje de programación con el que, entre otras cosas, está programado WordPress, los themes, los plugins, etc.

¿Necesitas actualizar la versión PHP de WordPress?

En realidad, la versión de PHP no se actualiza en WordPress en sí, ya que ahí lo único que se hace es ejecutarla o interpretarla, tal y como te contamos en nuestro Curso de Iniciación a WordPress. Donde tienes que actualizarla en el Servidor del hosting donde tienes alojado el sitio web.

Una vez aclarado esto, tienes que tener presente que la actualización de la versión PHP se realiza de forma periódica cuando incorporan mejoras, parches de seguridad, nuevas funcionalidades, corrección de errores etc.

Por este motivo, es muy importante que dispongas siempre de una versión actualizada de PHP, ya que en muchos casos será imprescindible para mantener seguro tu sitio WordPress.

¿Cómo actualizar la versión de php?

Ahora ya intuirás, por lo que te acabo de explicar, que para actualizar la versión PHP debes acudir hasta tu proveedor de hosting.

Por lo general, la mayoría de empresas de hosting utilizan CPanel (un panel de control para el usuario desde el que puede auto-administrar todo su hosting).

Una vez dentro de CPanel, debes buscar dentro del apartado “Software” un icono que se llama “Seleccionar versión de PHP”

actualizar-version-php-1

Una vez dentro de esta opción, verás que te aparece otra pantalla donde pone tu versión de PHP y un desplegable, con las últimas versiones disponibles, para que elijas la que necesites.

actualizar version php

Una vez que la has seleccionado, únicamente debes pulsar en el botón “Salvar” que aparece en la parte de abajo de la imagen y, de forma automática, tu servidor empezará a trabajar con esta versión.

No encuentras el icono de PHP

Hay determinadas empresas de hosting muy económicas que no ofrecen la opción de que el usuario pueda actualizar la versión de PHP instalada en el servidor.

En muchos casos podrás resolverlo enviando un ticket al departamento de soporte del hosting. Pero en otros casos, dependiendo de la configuración y recursos del servidor en el que han alojado, no te quedará más remedio de cambiar de proveedor de hosting.

Y recuerda que si quieres aprender más sobre WordPress, puedes suscribirte a nuestros 18 Cursos, con más de 221 vídeos. También tendrás acceso a una MasterClass mensual, soporte personalizado y descarga de plugins y themes Gratis.

Interacciones del lector

Comentarios

  1. Sin duda, importantísimo mantenerse actualizado y mucho cuidado a partir de la versión 5.0 de WordPress porque creo que van a cambiar los requisitos mínimos en cuanto a PHP.

    • Hola Dani!

      Gracias por pasarte por el blog y dejar tu comentario 😉

      Efectivamente, la versión 5.0 de WordPress se rumorea que va a ser compatible con PHP 7.3.

      Lo ideal es actualizar, por lo menos, a la penúltima que tenga disponible nuestro proveedor de hosting. En esa no corremos riesgo de que algo deje de funcionar, ya que será prácticamente compatible con todo, salvo que tengas plugins y themes desactualizados…

      Un saludo!

¿Tú qué opinas?

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

Al usar este formulario accedes al almacenamiento y gestión de tus datos por parte de esta web de acuerdo a nuestra política de privacidad *